Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Nueva RPI 4 ¡Atención!
#31
(07-07-2019, 08:18 PM)pinguino escribió: ...
En este caso no tenemos ese problema. Ni nos van a dejar tirados ni el código es cerrado. Solo es cuestión de tiempo y todo funcionara con las nuevas prestaciones incluidas.
Brindis
Saludos.

Responder
Ha recibido el agradecimiento de:
#32
(07-07-2019, 11:01 AM)pinguino escribió: Continuo con los detalles.

El súper guion para crear OpenPlotter todavía no funciona del todo bien. Da errores y tras tunearlo un poco logro que finalice pero da lugar a un OpenPlotter con errores donde el sistema no funciona bien. No se muestran los iconos gráficos y openplotter no termina de iniciar, creo que por el problema de los iconos.

Plan B. Instalar un Raspbian Buster limpio e ir aplicando uno a uno los diferentes guiones del super script. Algo he logrado. Tengo Opencpn, zygrib y parece que un openplotter que inicia y un sergvidor Signal K funcional.

Lo que funciona Bien: OpenCpn, con casi todos los plugins y Zygrib.

Lo que creo que funciona bien: Signal K y los datos a través del I2C para el IMU y supongo que pypilot... no estoy seguro hasta que pruebe. La gestión de las conexiones físicas también parece funcionar.

Lo que funciona a medias: OpenPlotter arranca pero hay cosas que no controla como el punto AP. Si funciona pero no se puede modificar a través de OpenPlotter. Hay que ir a mano al archivo hostapd correspondiente y tocarlo. Configurar la red con openplotter no parece funcionar por ahora.

Lo que no puedo comprobar: Los temas del Sombrero Moitessier y el SDR no los puedo comprobar al carecer del hardware correspondiente.

He probado este versión sobre la Rpi 3+ y funciona exactamente igual que sobre la 4.

Muy importante usar una SD de AL MENOS clase UHS-I. Mejor si superior. De otro modo fastidiamos por completo la experiencia de la Rpi 4. Con una vieja SD es igual de lenta que una Rpi 1 o 2. He usado una Rpi 3+ con disco SSD y la Rpi 4 sobre una SD de marca Samsumg UHS-I y va algo mas rápida la Rpi 4. A ver si meten ya el soporte para arranque directo desde  USB en la Rpi 4. Donde si machaca la 4 a la 3 es en la aceleración grafica. Los mapas MBTILes que en la 3 funcionan a tirones en la 4 van fluidos.

Si tenéis una Rpi 4 conviene actualizar la BIOS -si lleva una pequeña BIOS- para añadir el soporte a la gestión de energía y bajar la temperatura de la CPU. Merece la pena.

El super script para generar imágenes de openplotter (de ahora en adelante "openplotter-gen") si que funciona. El problema es que hay un bug importante en el emulador utilizado (Qemu) que genera una imagen sin errores pero defectuosa. El bug se manifiesta cuando intentamos ejecutar openplotter-gen en un i386 de 64bits. La solución es ejecutar openplotter-gen en un sistema arm como hace la gente de Raspberry o lo que hago yo que es crear un sistema virtual Debian Buster de 32bits y ejecutar openplotter-gen en él.

Tu plan B es una opción pero es mucho trabajo y no conseguirás una imagen tan ligera. Prueba un virtualbox con debian buster 32bits en ubuntu y no tendras problemas. Si compartes las imágenes que generes deja bien claro que es una versión en desarrollo no apta para navegar y de la que no atenderemos a reportes hasta que no empiece la fase beta.

Ha salido una nueva version de la BIOS para la RPi4? donde lo miras eso? puede que sea la solucion al problema con los SDR

Lamentablemente hemos tenido que abandonar voluntariamente este foro por la presencia de contenido discriminatorio hacia colectivos desfavorecidos por razones de género, raza, religión y cultura. Entendemos que este tipo de contenidos no deberían de tolerarse en este ni en ningún medio público ni privado.

Emplazamos a las usuarias y usuarios del proyecto OpenPlotter a continuar con su desarrollo en el sitio oficial forum.openmarine.net donde la lengua preferente y vehicular es el inglés pero donde podrás expresarte en la lengua que desees. Cualquier contenido que atente contra los colectivos anteriormente citados será eliminado y sus autores o autoras expulsados sin previo aviso.

Salut i tota la bona sort del món a foronavegantes.net  Velero
Responder
Ha recibido el agradecimiento de:
#33
Entiendo entonces que el problema de los iconos se debe al bug de qemu. No obstante se paraba el pi-gen en la instalación de la sección 7. A veces por error con npm, otras con node-red o grafana. Puede que los repos estuvieran siendo modificados en ese momento, no se.

Respecto al firmware echale un vistazo a esto:

https://misapuntesde.com/post.php?id=906

Podrían ir los tiros por ese lado ya que hay quien vincula cierto firmware con errores con los puertos usb 3.0 que entran en modo ahorro inesperadamente.
No es que el mar tenga tan mal carácter.
El verdadero canalla es el viento.
El mar... sencillamente se deja llevar.
Responder
Ha recibido el agradecimiento de:
#34
(08-07-2019, 02:02 PM)pinguino escribió: Entiendo entonces que el problema de los iconos se debe al bug de qemu. No obstante se paraba el pi-gen en la instalación de la sección 7. A veces por error con npm, otras con node-red o grafana. Puede que los repos estuvieran siendo modificados en ese momento, no se.

Respecto al firmware echale un vistazo a esto:

https://misapuntesde.com/post.php?id=906

Podrían ir los tiros por ese lado ya que hay quien vincula cierto firmware con errores con los puertos usb 3.0 que entran en modo ahorro inesperadamente.

Si, lo de los iconos y otros no visibles a simple vista.
El error de npm es debido a esto: https://github.com/SignalK/signalk-serve...issues/823
y el de los otros paquetes puede que sea debido a fallos puntuales en tu conexion, teniendo en cuenta que necesitas unas cuantas horas para generar completar el script no es raro que alguno de los pasos se encuentre con problemas.

Lamentablemente hemos tenido que abandonar voluntariamente este foro por la presencia de contenido discriminatorio hacia colectivos desfavorecidos por razones de género, raza, religión y cultura. Entendemos que este tipo de contenidos no deberían de tolerarse en este ni en ningún medio público ni privado.

Emplazamos a las usuarias y usuarios del proyecto OpenPlotter a continuar con su desarrollo en el sitio oficial forum.openmarine.net donde la lengua preferente y vehicular es el inglés pero donde podrás expresarte en la lengua que desees. Cualquier contenido que atente contra los colectivos anteriormente citados será eliminado y sus autores o autoras expulsados sin previo aviso.

Salut i tota la bona sort del món a foronavegantes.net  Velero
Responder
Ha recibido el agradecimiento de:
#35
Lo he probado en una Rpi y se se ha construido bien. 
El resultado ha sido similar al de hacerlo a pelo. Los mismos problemillas se repiten. Desde luego no esta para ponerla a prueba todavia.

Por cierto el IMU no lo detecto pese a que salia el 68 en el i2cdetect. Configurar las entradas fisicas sin monitores fue complicado pero se logró. ¿kplex ha pasado al banquillo?
No es que el mar tenga tan mal carácter.
El verdadero canalla es el viento.
El mar... sencillamente se deja llevar.
Responder
Ha recibido el agradecimiento de:
#36
cada dia me pierdo mas,que carallao es eso de la rabpi o como se llame y el opencpn,creo que el opnencpn va bien,son cosas distintas??????a rañala,no quiero saber más nada de tegnologia jujujujuju el opencpn vá bien,cualquier dia me sacais un plano de la luna jujujujujujujujujuju enhorabuena por vuestro curre aunque no tenga ni puta idea jujujujujujuju a rañala con cariño jujujujuju
Los sueños son la semilla de la accion .  Patron
    a rañala....
FACE:elsueñodehippie
Responder
Ha recibido el agradecimiento de:
#37
(09-07-2019, 01:31 PM)Hippie escribió: cada dia me pierdo mas,que carallao es eso de la rabpi o como se llame y el opencpn,creo que el opnencpn va bien,son cosas distintas??????a rañala,no quiero saber más nada de tegnologia jujujujuju el opencpn vá bien,cualquier dia me sacais un  plano de la luna jujujujujujujujujuju enhorabuena por vuestro curre aunque no tenga ni puta idea jujujujujujuju    a rañala con cariño jujujujuju
Hippie, la Rasberry Pi no es mas que un pequeño ordenador muy barato y que cabe en la palma de la mano.
[Imagen: raspberry-pi-2-hand-v2-1500x1000.jpg]
Como cualquier ordenador puede correr OpenCpn y por eso nos gusta a muchos.

La enchufamos a una tele, le ponemos un teclado y OpenCpn y a navegar.
No es que el mar tenga tan mal carácter.
El verdadero canalla es el viento.
El mar... sencillamente se deja llevar.
Responder
Ha recibido el agradecimiento de: Hippie
#38
(09-07-2019, 12:24 PM)pinguino escribió: Lo he probado en una Rpi y se se ha construido bien. 
El resultado ha sido similar al de hacerlo a pelo. Los mismos problemillas se repiten. Desde luego no esta para ponerla a prueba todavia.

Por cierto el IMU no lo detecto pese a que salia el 68 en el i2cdetect. Configurar las entradas fisicas sin monitores fue complicado pero se logró. ¿kplex ha pasado al banquillo?

A que te refieres con "los problemillas se repiten"? a los problemas derivados del openpotter-gen o de las cosas en desarrollo?

no es que kplex haya pasado al banquillo si no todo lo contrario, lo liberamos como herramienta externa y autonoma para que se pueda dedicar a tareas especificas. No tenia sentido que estuviera en medio de las entradas serial/network y signal k siempre obligatoriamente. Ahora las entradas serials se crean en la pestaña serial y van directamente a signal k y las entradas de red se crean directamente en signal k. kplex es una buena herramienta que estabamos infrautilizando obligandole a estar en medio del flujo de datos aunque no estuviera justificado.

Lamentablemente hemos tenido que abandonar voluntariamente este foro por la presencia de contenido discriminatorio hacia colectivos desfavorecidos por razones de género, raza, religión y cultura. Entendemos que este tipo de contenidos no deberían de tolerarse en este ni en ningún medio público ni privado.

Emplazamos a las usuarias y usuarios del proyecto OpenPlotter a continuar con su desarrollo en el sitio oficial forum.openmarine.net donde la lengua preferente y vehicular es el inglés pero donde podrás expresarte en la lengua que desees. Cualquier contenido que atente contra los colectivos anteriormente citados será eliminado y sus autores o autoras expulsados sin previo aviso.

Salut i tota la bona sort del món a foronavegantes.net  Velero
Responder
Ha recibido el agradecimiento de:
#39
(09-07-2019, 04:11 PM)Sailoog escribió: A que te refieres con "los problemillas se repiten"? a los problemas derivados del openpotter-gen o de las cosas en desarrollo?

no es que kplex haya pasado al banquillo si no todo lo contrario, lo liberamos como herramienta externa y autonoma para que se pueda dedicar a tareas especificas. No tenia sentido que estuviera en medio de las entradas serial/network y signal k siempre obligatoriamente. Ahora las entradas serials se crean en la pestaña serial y van directamente a signal k y las entradas de red se crean directamente en signal k. kplex es una buena herramienta que estabamos infrautilizando obligandole a estar en medio del flujo de datos aunque no estuviera justificado.
En este caso, el openplotter-gen ha funcionado bien, sin errores. La imagen ha salido correcta y funciona con normalidad. Los errores a los que hacia referencia corresponde a openplotter 2. La imposibilidad de modificar las características del AP a través de openplotter, el no reconocer el IMU y el comportamiento algo errático del gestor de puertos Serie -había que reiniciar openplotter tras cada asignación individual o no se guardaban, falta un monitor de datos de los puertos para ver que es cada uno-, al menos por ahora.

Signal k parecía ir bien y kplex, que usé para enviar gps y sonda a Navionics Boating, también iban bien. Esto es mas o menos por encima. Pero soy consciente de que el salto de OP 1.2 a OP 2 es enorme y hay mucho que pulir.
No es que el mar tenga tan mal carácter.
El verdadero canalla es el viento.
El mar... sencillamente se deja llevar.
Responder
Ha recibido el agradecimiento de:
#40
(09-07-2019, 04:56 PM)pinguino escribió: En este caso, el openplotter-gen ha funcionado bien, sin errores. La imagen ha salido correcta y funciona con normalidad. Los errores a los que hacia referencia corresponde a openplotter 2. La imposibilidad de modificar las características del AP a través de openplotter, el no reconocer el IMU y el comportamiento algo errático del gestor de puertos Serie -había que reiniciar openplotter tras cada asignación individual o no se guardaban, falta un monitor de datos de los puertos para ver que es cada uno-, al menos por ahora.

Signal k parecía ir bien y kplex, que usé para enviar gps y sonda a Navionics Boating, también iban bien. Esto es mas o menos por encima. Pero soy consciente de que el salto de OP 1.2 a OP 2 es enorme y hay mucho que pulir.

OK, gracias.

Gestor de puertos serie arreglado, daba un error si no existía kplex.conf.

En esta pagina podrás ver el progreso del desarrollo: https://github.com/sailoog/openplotter/projects/4

Lamentablemente hemos tenido que abandonar voluntariamente este foro por la presencia de contenido discriminatorio hacia colectivos desfavorecidos por razones de género, raza, religión y cultura. Entendemos que este tipo de contenidos no deberían de tolerarse en este ni en ningún medio público ni privado.

Emplazamos a las usuarias y usuarios del proyecto OpenPlotter a continuar con su desarrollo en el sitio oficial forum.openmarine.net donde la lengua preferente y vehicular es el inglés pero donde podrás expresarte en la lengua que desees. Cualquier contenido que atente contra los colectivos anteriormente citados será eliminado y sus autores o autoras expulsados sin previo aviso.

Salut i tota la bona sort del món a foronavegantes.net  Velero
Responder
Ha recibido el agradecimiento de:
#41
jor,cada dia odio más los ordenadores y la realidad virtual,porque todos los que estamos aqui ante de que se haga mas grande,no hacemos una quedada,total nos vamos a morir igual.......ya sé que alguna vez vamos a cpoincidir en algun lado,pero me refiero a quedar en algun lado todos juntos ,dá igual sea navidad o verano,antes de que esto cresca más,me gustaria conocer a mas de un@,solo quiero conoceros,aunque seais feoss.....a rañala
Los sueños son la semilla de la accion .  Patron
    a rañala....
FACE:elsueñodehippie
Responder
Ha recibido el agradecimiento de:
#42
(09-07-2019, 10:12 PM)Hippie escribió: ...,solo quiero conoceros,aunque seais feoss.....a rañala

Yo soy feo, pero feo, feo, feo. Puedes asustarte y todo.
Meparto
Saludos.

Responder
Ha recibido el agradecimiento de: Hippie
#43
Continuo... tras probarlo en navegación ahora puedo confirmar que el gestor de dispositivos físicos funciona bien. También funciona correctamente el IMU.

El AP continua como antes. No se puede gestionar con openplotter, no reacciona a los cambios guardados. También me ha sido imposible configurar un puerto serie en modo both -entrada y salida a la vez sin consecuencias.

Finalmente he recurrido a kplex y lo he logrado pero teniendo que añadir una entrada 10110 a kplex y haciendo que el gestione la entrada-salida del dispositivo seatalk. Como consecuencia he perdido esos datos en el entorno de signal K. Creo que para hacerlo bien necesitare un dispositivo serie adicional.

Respecto a la Rpi 4. Ahora que todo lo que un servidor usa funciona -mas o menos- bien, he de reconocer que cambia la experiencia totalmente. Todo va mas fluido. Los flujos NMEA, el VNC, la navegación por Internet, opencpn, zygrib. La temperatura no sube mas que la Rpi 3. Tras usar el firm nuevo yo diría que incluso va mejor y no he necesitado ningún alimentador especial, tan solo el mismo que usaba con la Rpi3.

Al compilar opencpn la rpi 3 petaba si la ponías a trabajar a mas de dos núcleos. La Rpi 4 lo ha hecho a tope con los 4 núcleos sin colgarse ya que la RAM sobraba a diferencia de la Rpi3.

Solo un detalle. Una Rpi 4 de 1 GB no tiene sentido en mi opinión. Lo ideal es la de 2 gb para exprimirla bien. La de 4 gb me parece demasiado y pienso que el equilibrio justo esta en la de 2 gb. Ahora bien, si queremos usarla para algo de procesado de imágenes o con muchas pestañas en el navegador puede ser nuestra elección, pero yo recomiendo la de 2 gb.

He compilado mi versión de opencpn para buster ya que el sonido no funciona bien en la versión original de opencpn. En la mía va bien y permite usar sonidos mp3 cosa que la original no permite.
No es que el mar tenga tan mal carácter.
El verdadero canalla es el viento.
El mar... sencillamente se deja llevar.
Responder
Ha recibido el agradecimiento de:
#44
Atención, problema con el cable cargador. El oficial es defectuoso.
Aquí la noticia.
Saludos.

Responder
Ha recibido el agradecimiento de:
#45
Mas que con el cargador es con ciertos cables. Sobre todo con los de la manzana. Yo he usado los del movil LG perfectamente y en el barco uso el convertidor que tenia de la RPI 3
No es que el mar tenga tan mal carácter.
El verdadero canalla es el viento.
El mar... sencillamente se deja llevar.
Responder
Ha recibido el agradecimiento de:


Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)